Search found 27 matches

by premiumroast
Wed Sep 24, 2014 11:22 am
Forum: Technical Discussion
Topic: Running Rich
Replies: 6
Views: 2108

Re: Running Rich

Yea, that would be it. Its located near the carbeuramlamajiggers. Bike still runs rich (wish I did) and it recently decided to only run on 3 cylinders. Pretty sure the problem is fuel flow and not spark but will be digging into it this weekend.
by premiumroast
Wed Sep 17, 2014 1:54 pm
Forum: Technical Discussion
Topic: Running Rich
Replies: 6
Views: 2108

Re: Running Rich

CB650 I think I got part of it sorted....someone was monkeying around with the throttle idle adjustment dial.
by premiumroast
Thu Sep 11, 2014 3:19 pm
Forum: Technical Discussion
Topic: Running Rich
Replies: 6
Views: 2108

Running Rich

Been a while since I've been on here but the bike is running now! Ignition issue fixed, new throttle assembly, fork tubes resealed, and new headlight assembly all wired up! Huge improvement. Battery seems a little weak but after so many times of cranking it over and draining it, it probably makes se...
by premiumroast
Mon Apr 28, 2014 8:08 pm
Forum: Technical Discussion
Topic: Tach and Speedo from a Honda Shadow
Replies: 2
Views: 1159

Re: Tach and Speedo from a Honda Shadow

Flamdchicken, thanks for the info! I will do a little research and check tire sizes of the bikes and see if I can find a little comparative info between the tachs. If I can manage to get them to working it would be great since I picked up both and a rear fender for a cool $20!!
by premiumroast
Mon Apr 28, 2014 2:45 pm
Forum: Technical Discussion
Topic: Tach and Speedo from a Honda Shadow
Replies: 2
Views: 1159

Tach and Speedo from a Honda Shadow

Anyone have any insight into changing out speedo and tach on an 83 CB650? I picked up a speedo and tach off a Honda Shadow and am wondering if it would work?
by premiumroast
Sun Jan 26, 2014 9:44 pm
Forum: Technical Discussion
Topic: Aftermarket speedo and tach for 83 Honda CB650
Replies: 0
Views: 2978

Aftermarket speedo and tach for 83 Honda CB650

I've been casting around online looking at various compatible speedos and tachs. Best ones I have found so far are the minis from Dime City Cycles, but I am wondering if anyone has thoughts on other aftermarket suppliers they have used successfully?
by premiumroast
Fri Oct 18, 2013 1:52 pm
Forum: Accessories and Apparel
Topic: Wanted intact starter/kill switch assembly for 83 CB650SC
Replies: 25
Views: 12431

Re: Wanted intact starter/kill switch assembly for 83 CB650S

Here is a photo of the switch wiring harness (finally)
by premiumroast
Fri Oct 18, 2013 1:41 pm
Forum: Technical Discussion
Topic: Running but bogs when re started after sitting
Replies: 9
Views: 2566

Re: Running but bogs when re started after sitting

It runs on all four but after a short ride it drops the two inside ones and then stalls. When I let it sit for a while and restart it, it will again run on all four. I still need to get to the stuff that usbear suggested I check. Damn hockey season.
by premiumroast
Tue Oct 08, 2013 1:06 pm
Forum: Technical Discussion
Topic: Running but bogs when re started after sitting
Replies: 9
Views: 2566

Re: Running but bogs when re started after sitting

usbear: Have not been able to get to any of the stuff you suggested yet (I work in pro hockey so home opener ate up my weekend) I have a suspicion that it might be a bad coil because when I had the plug wires mixed up the cylinders I had them routed to off the right side coil didn't run. Any thought...
by premiumroast
Tue Oct 01, 2013 11:56 am
Forum: Technical Discussion
Topic: Running but bogs when re started after sitting
Replies: 9
Views: 2566

Re: Running but bogs when re started after sitting

Will get cracking on that. Thanks usbear!
by premiumroast
Mon Sep 30, 2013 7:44 pm
Forum: Technical Discussion
Topic: Running but bogs when re started after sitting
Replies: 9
Views: 2566

Running but bogs when re started after sitting

Got my 83 CB650 to the point of running and rideable! Took a few laps around the bay and stopped to visit a friend. Bike sat for about 20 minutes and when restarted would barely run and was loping along on two cylinders. Pulled the plugs and they looked pretty fouled. Bought new plugs today (replace...
by premiumroast
Fri Sep 27, 2013 9:49 am
Forum: Technical Discussion
Topic: Clutch not engaging
Replies: 5
Views: 2036

Re: Clutch not engaging

I can send a picture of the plug/pin configuration to see if it is compatible if that is ok?
by premiumroast
Thu Sep 26, 2013 11:13 am
Forum: Technical Discussion
Topic: Clutch not engaging
Replies: 5
Views: 2036

Re: Clutch not engaging

cb650: Fixed! Bled the line and got all the air out of it. Was able to shift smoothly through all six gears and back to neutral. Did you still have that intact starter switch with the wiring assembly? Turns out the one off the 85 is not compatible. I need one for my 83 CB650. Thanks!
by premiumroast
Sun Sep 22, 2013 11:34 am
Forum: Accessories and Apparel
Topic: Wanted intact starter/kill switch assembly for 83 CB650SC
Replies: 25
Views: 12431

Re: Wanted intact starter/kill switch assembly for 83 CB650S

Ghost: Thanks! Once it get the bike consistently running on all four cylinders (it sometimes drops to three and I am sure it is spark related) and get the clutch compression sorted out I can take it out for a ride.
by premiumroast
Fri Sep 20, 2013 12:49 pm
Forum: Accessories and Apparel
Topic: Wanted intact starter/kill switch assembly for 83 CB650SC
Replies: 25
Views: 12431

Re: Wanted intact starter/kill switch assembly for 83 CB650S

Got the plug, and front brake solved, getting close to a working clutch, but need to know if the starter/kill switch and wiring assembly is the same as the 83? I can get one for an 84 for about $30.

Go to advanced search