Stator replacement issues

General motorcycle conversation

Moderators: Volker_P, tidd650

CPowell1994
Posts: 34
Joined: Wed Feb 14, 2018 8:51 am

Stator replacement issues

Postby CPowell1994 » Sat Feb 17, 2018 8:22 pm

So I got a new stator for my '80 custom. The wiring isn't the same. The small green wire and small blue wire seem to run from the locations pictured, to the smaller plug pictured that runs along the original stator harness. My new stator doesn't have those wires, but (as pictured) has two small wires; one black, one white, that end in little blade connectors. I'm not quite understanding what to do here. Anybody have an idea?
Attachments
IMG_20180217_175906.jpg
IMG_20180217_175906.jpg (3.04 MiB) Viewed 567 times
IMG_20180217_201311.jpg
IMG_20180217_201311.jpg (3.62 MiB) Viewed 567 times
IMG_20180217_201343.jpg
IMG_20180217_201343.jpg (3.36 MiB) Viewed 567 times
Loud pipes save lives. Pissing off everyone around you is just a bonus.

CPowell1994
Posts: 34
Joined: Wed Feb 14, 2018 8:51 am

Re: Stator replacement issues

Postby CPowell1994 » Sat Feb 17, 2018 8:23 pm

Green wire
Attachments
IMG_20180217_175855.jpg
IMG_20180217_175855.jpg (3.33 MiB) Viewed 566 times
Loud pipes save lives. Pissing off everyone around you is just a bonus.

CPowell1994
Posts: 34
Joined: Wed Feb 14, 2018 8:51 am

Re: Stator replacement issues

Postby CPowell1994 » Sat Feb 17, 2018 9:18 pm

Figured it out. I ordered the wrong stator. Going to order the correct one as soon as I can.
Loud pipes save lives. Pissing off everyone around you is just a bonus.

User avatar
Folsoml
Posts: 1610
Joined: Sat Apr 07, 2012 9:02 pm
Location: North Florida

Re: Stator replacement issues

Postby Folsoml » Sat Feb 17, 2018 10:04 pm

Just so you know, the green wire is your neutral switch and the blue one is your oil pressure switch.
Have a problem with your CB650? Have a technical question? Click here!


My Current Bikes: 2005 HD FLHTCUI Electra Glide Ultra Classic, 2007 Yamaha Vino,

User avatar
Volker_P
Posts: 5313
Joined: Mon Mar 06, 2006 1:53 am
Location: southern Germany

Re: Stator replacement issues

Postby Volker_P » Wed Feb 28, 2018 2:56 am

Right.
The stator itself only needs the three yellow wires for operation.
Black and white are to connect the regulator to the rotor brushes.
These five cables share the same plug to the regulator, so probably that's why b&w they are there, too.

I guess from this and the pictures you could still have a CB650 aftermarket stator there.
Of course you may have detected other reasons why this one does not fit however. :wink:
Cosky's great (free) online manual: http://cosky0.tripod.com

forum links to common technical issues


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests