'79 CB650 turn signal problems

General motorcycle conversation

Moderators: Volker_P, tidd650

Widerman
Posts: 3
Joined: Mon May 30, 2016 10:18 pm

'79 CB650 turn signal problems

Postby Widerman » Tue Jun 11, 2019 8:10 pm

Good evening everyone.

I am new to posting on the forum but I have used plenty of different threads to help with my restoration of my CB650. Thank you all.

The CB650 has the stock wiring harness, and stock left handlebar switches. I have aftermarket turn signals from Dime City Cycles (link is below). They are said to be a drop in part that should work with the flasher relay since they are not LED turn signals. I also have a two pronged flasher relay with a B and L on the top (guessing B means battery and L meaning lights).

So here is my problem. When I turn the bike on the running lights on the bike work and when I turn the signals on left and right they do not blink but the other light does turn off. I have tried multiple flasher relays and I have the same results.

I would like to know how to test my left handlebar switches and the wires to flasher relay to make sure that I have power at the switches and at the relay point.

If you need any more information please let me know.

Thanks for any help.
Widerman

Lights from Dime City Cycle
http://HTTP://www.dime citycycles.com/-25-8301cm.HTML

User avatar
GeorgeSweety
Posts: 418
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 turn signal problems

Postby GeorgeSweety » Wed Jun 12, 2019 1:55 am

Hello Widerman and welcome, please check out the posts in this link if you haven't already. viewtopic.php?f=4&p=95473#p95473
The solution to your problem may be as simple as this.........hopefully!

User avatar
GeorgeSweety
Posts: 418
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 turn signal problems

Postby GeorgeSweety » Wed Jun 12, 2019 2:00 am

Widerman wrote:
Lights from Dime City Cycle
http://HTTP://www.dime citycycles.com/-25-8301cm.HTML


The link won't work for me, only part of the link is highlighted but even copy & pasting it into my browser search won't open the link.

User avatar
Volker_P
Posts: 5379
Joined: Mon Mar 06, 2006 1:53 am
Location: southern Germany

Re: '79 CB650 turn signal problems

Postby Volker_P » Wed Jun 12, 2019 2:50 am

Cosky's great (free) online manual: http://cosky0.tripod.com

forum links to common technical issues

Widerman
Posts: 3
Joined: Mon May 30, 2016 10:18 pm

Re: '79 CB650 turn signal problems

Postby Widerman » Wed Jun 12, 2019 7:08 pm

Thank you Volker_P. That is the correct link. Not sure what happened with the link when I published the post.

I have figured out that the flasher relay takes the White with Green strip and the Grey wire that runs to it. I have found that I do not have continuity in the grey wire to the left handlebar switch. This is the only location that the wire runs to. I have tested the continuity in the handlebar switch and the grey wire only runs from the relay switch to the left handlebar switch.

GeorgeSweety thanks for the link. I don't believe that the bulbs are the wrong size/watts. I am going to call Dime City Cycles tomorrow to confirm that the bulbs are correct.

So.....tomorrow I am going to run a secondary wire to "replace" the grey wire up to the "quick disconnect" bundle. I hope that this works.

We will see what tomorrow brings. Thanks again you guys!


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 7 guests