Running rough after new (to me) gas tank

If it's broken or just needs tweaked

Moderators: Volker_P, tidd650

zachiepie
Posts: 3
Joined: Wed Jun 28, 2017 12:47 pm

Running rough after new (to me) gas tank

Postby zachiepie » Wed Nov 01, 2017 8:48 pm

I'm having an issue with my previously well-running 82 CB650SC. My old tank was rusted beyond repair, and I found a new one on eBay. The tank looked like it was in great condition, and as far as I could see, there wasn't any rust on the inside of the tank. I installed it, put gas in it, and ran it. During my next ride, the bike acted up. It sounded like it was misfiring, and it would die when I idled it at a stop sign or wherever. I got it home, and the left cylinders did not seem to be firing. The exhaust pipes were cold, and the carbs were full of gas when I drained them (to make sure they were getting gas). When I inspected the gas that came from the left carbs, I noticed a bunch of reddish appearing flecks. I didn't see any on the right hand carbs.

I installed a new inline fuel filter (to replace the old one) and revved it in the garage to higher RPMs. I still can't get those cylinders to fire right. There is spark and I'm still getting gas in the carbs.

Is my only option now to remove the carbs and clean everything out?

cb650
Posts: 2943
Joined: Fri Mar 03, 2006 7:20 am
Location: Denver CO USA
Contact:

Re: Running rough after new (to me) gas tank

Postby cb650 » Thu Nov 02, 2017 4:40 am

yes sounds like rust in the bottom. The carbs might clear up but??? always clean the tank out. I have bought several "good" tanks to find them full of shit.
Did you clean the tank out?!?!?!?!

User avatar
Folsoml
Posts: 1621
Joined: Sat Apr 07, 2012 9:02 pm
Location: North Florida

Re: Running rough after new (to me) gas tank

Postby Folsoml » Thu Nov 02, 2017 5:20 am

If rust got in the carbs and plugged a jet or two, it will not work itself out. Carbs will have to come off for a thorough cleaning. Give the tank a good cleaning as well while you are at it.
Have a problem with your CB650? Have a technical question? Click here!


My Current Bikes: 2005 HD FLHTCUI Electra Glide Ultra Classic, 2007 Yamaha Vino,


Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 23 guests