'79 CB650 Front Turn Signal Wiring Issue

If it's broken or just needs tweaked

Moderators: Volker_P, tidd650

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

'79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Mon Jun 03, 2019 10:05 pm

Hey all! I have already found a lot of help on this site. Helped with my chain, sprocket, and adjustment issues.

My bike was bought with a faring on it. I have always wanted to get a headlight and turn signals to take the faring off because I like the look better and I don't take it on far trips. So I bought a cheap universal headlight and turn signal combo. Already learned how to wire up the headlight and fog light (all in one), but I'm struggling with correctly wiring the turn signals.

The bike has for one side 3 wires, orange, orange and white and green for ground and light blue and light blue and white for the other side. The turn signals only have 2 wires, ground and solid color. Whenever I hook up the solid to solid and ground to ground and I turn on the turn signal switch, it doesn't blink. Any ideas?

Also, in the faring, it had turn signal lights built in and neither side used the "and white" wires, and it worked just fine. So, as I said, any help or ideas? Thanks in advance guys and gals! Have a great week!

User avatar
GeorgeSweety
Posts: 391
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby GeorgeSweety » Tue Jun 04, 2019 1:50 am

Hi benrobbie, I presume that you are in the US where your bikes usually have the front turn signals (indicators in the UK) always illuminated? In the UK this isn't a legal requirement so the "constant on" front turn signals are usually disabled by disconnecting one wire on Imported motorcycles, can't remember which though :oops: !
But here is a similar problem I encountered when I put aftermarket turn signals on my Royal Enfield. I connected up the two wires to each turn signal and nothing worked, easy.....swap the wires over.....nothing worked, no flash.....nothing! Head scratching and cursing didn't produce any results :x then I literally had a light bulb moment :idea: I changed the bulbs over from the standard signals to the aftermarket ones and bingo, flashes everywhere :) It turned out that the "Foreign" made aftermarket turn signals had a completely different wattage bulbs that would not flash on the Enfields electrics.
I'm not saying this will fix yours but if you can change the bulbs with the ones in your fairing and see if that works, failing that I'll pop the headlight on my bike and see what connects to what. Good Luck!

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Tue Jun 04, 2019 11:09 am

I was able to stick the old bulb in. When I did, it blinked. In my state in the US, it's not required to stay on. But the old bulb's glass is too big for the new signal. Gotta get new ones. Thanks so much!!

User avatar
GeorgeSweety
Posts: 391
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby GeorgeSweety » Tue Jun 04, 2019 11:13 am

You are most welcome mate, glad I could help and thanks for letting us know that you found the solution :D Regards, George.

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Tue Jun 04, 2019 4:44 pm

Well, found out my problem and it is NOT in the manual wiring chart. I thought it was the bulb size, partially was, but to get these bulb's to work, I had to attach the orange, then the light blue wire to the solid brown wire on the bike, which went to positive of the lights, then it clicks/blinks. Woohoo!! Weird!!

Alas, while trying to get the turn signals to work, the headlight ceased to work, even though I had it working earlier. I think that I blew the fuse, but I have no idea where the fuses are. I know where the main 30 amp fuse is, other than that no clue. Any help?

User avatar
GeorgeSweety
Posts: 391
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby GeorgeSweety » Wed Jun 05, 2019 2:00 am

It depends which model the bike is, on my CB650SC Nighthawk and my CB650 Custom it is under the plastic cover between the handlebars, on my CB650Z I have no idea but I presume it would be around the same area. I have owned my CB650Z for about a year but its in the back of my shed on my "To Do" list and TBH I've never really checked the bike over :roll:

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Wed Jun 05, 2019 6:32 am

Thank you for your assistance. My bike is a plain old '79 CB650.

vbhvmlk
Posts: 2
Joined: Wed Aug 30, 2017 9:01 am

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby vbhvmlk » Fri Jun 21, 2019 12:08 pm

The fuse box is on the handlebar mount on the Z


Sent from my iPhone using Tapatalk

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Fri Jun 21, 2019 1:03 pm

Thank you vbhvmlk. It was on the handlebars. Yes, it was a fuse, still had an extra one right there. Still getting it wired up, but all should be good. Been VERY busy with other stuff, you know, life stuff. :^) Thanks to all for your assistance.

vbhvmlk
Posts: 2
Joined: Wed Aug 30, 2017 9:01 am

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby vbhvmlk » Fri Jun 21, 2019 1:13 pm

benrobbie wrote:Thank you vbhvmlk. It was on the handlebars. Yes, it was a fuse, still had an extra one right there. Still getting it wired up, but all should be good. Been VERY busy with other stuff, you know, life stuff. :^) Thanks to all for your assistance.

You are welcome.
I am also finishing up a Euro 80 650Z , have yet to get to wiring up the blinkers.


Sent from my iPhone using Tapatalk

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Wed Jun 26, 2019 2:30 pm

Just wanted to show you guys a before and after shot of my bike. Thanks again for all the help. Still have lots to do, but I'm loving it! I also recently upgraded my chain and sprockets. From 16t/40t combo to a 17t/38t combo. Wow, what a difference! Anyway, pretty pumped about it.
Attachments
IMG_3836.jpg
Before
IMG_3836.jpg (1 MiB) Viewed 208 times
motorcycle 2.jpg
After
motorcycle 2.jpg (1.37 MiB) Viewed 208 times

User avatar
GeorgeSweety
Posts: 391
Joined: Tue Aug 08, 2017 11:47 am
Location: UK.

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby GeorgeSweety » Thu Jun 27, 2019 4:03 am

I can see why you wanted to remove the fairing, it looks so much better without it 8)

Mr_Crow
Posts: 20
Joined: Wed Jun 12, 2019 10:16 am

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby Mr_Crow » Thu Jun 27, 2019 6:42 am

I think the faring is glorious!

jk jk :lol: that bike looks great now, good job!

benrobbie
Posts: 9
Joined: Fri Aug 21, 2015 3:20 pm

Re: '79 CB650 Front Turn Signal Wiring Issue

Postby benrobbie » Thu Jun 27, 2019 12:15 pm

Thanks guys. I want to get a windshield, but yeah, it looks so much better!!


Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 17 guests